L'extension AdGuard AdBlocker affectée par le dernier snapshot Vivaldi

17 janv. modifié dans Rapporter des bugs

Bonjour,

Il est difficile de reproduire le bug si l'on ne dispose pas du produit Adguard PC complet. Couplé à l'extension du même nom, Il offre une souplesse incomparable, notamment la possibilité de désactiver le filtrage à la volée; l'icone bleue se change en icone grise signifiant qu'après rechargement de la page, il n'y a plus de filtrage
https://i.postimg.cc/rmGSHSwM/screenshot-160.png

Cette fonction ne marche plus depuis le dernier snapshot 2.3.1420.4 (Version officielle) (32 bits) : la page se recharge l'icone est tjrs bleue; le filtrage est tjrs actif.

Extension AdGuard AdBlocker : https://chrome.google.com/webstore/detail/adguard-adblocker/bgnkhhnnamicmpeenaelnjfhikgbkllg

Réponses

  • Peu de chances que qq'un utilise Adguard PC. Au cas où qq'un pourrait faire avancer mon dossier ...

    VB-48351

    To reproduce the bug you must have the complete Adguard PC product.
    Combined with the AdGuard AdBlocker extension, it offers unbeatable flexibility, including the ability to temporarily disable filtering.

    To check the bug, I reinstalled the snapshot 1401.7 : the extension works fine

    AdGuard AdBlocker : https://chrome.google.com/webstore/detail/adguard-adblocker/bgnkhhnnamicmpeenaelnjfhikgbkllg

    By disabling on-the-fly filtering with the blue button of the extension :
    - a popup should indicate that a new rule has been added
    - the page should reloads immediately without any filter
    - the button should turns grey.

    Screenshot of this bug reported on the Adguard forum could help clarifying : https://forum.adguard.com/index.php?threads/adguard-pc-chrome-extension-broken-vivaldi-browser.30463/#post-175789

    Unfortunately :
    - no new rule popup
    - the page reloads, but filtering is not suspended
    - extension button remains blue

  • Salut,
    Ton bug n'est pas encore confirmé sur le bug tracker mais je le suis de près.
    Ça doit être lié au passage des snapshots en Chromium72.
    Si tu peux tester si c'est reproductible avec un Chrome/Chromium motorisé par une version 72 équivalente du moteur Chromium ?
    Vérifier aussi que l'extension est à jour et bien compatible avec Chromium72

  • Bonjour Testudo,
    Je viens de tester la désactivation du filtrage à la volée d'AdGuard AdBlocker avec la dernière snapshot (1430.4). Tout semble fonctionner correctement (étant sur Linux, je ne peux pas installer Adguard PC complet).
    image
    image

  • 23 janv. modifié

    Salut et merci à vous deux.

    @ramon très bonne suggestion que la tienne. J'ai eu un mal fou à m'y retrouver ds le catalogue des versions et des variantes de chromium. J'ai trouvé une fourchette en partant d'une version 71 et du latest snapshot 73 : le bug ne tombe pas excatement sur le passage à la 72 ainsi que l'indique mon screen; je pourrais affiner encore mais est-ce bien nécessaire ?

    screenshot-166
    Que me suggères-tu pour faire avancer les choses ?

    @FarStar tu as tout à fait raison : l'extension nue fonctionne correctement.

  • Salut,
    Bravo et merci pour ces tests multiversions !
    Donc tu n'arrives pas à faire fonctionner ton bazar d'AdGuard sur un Chromium de base à partir de la version 72.0.3624.0. et tu as rapporté bug avec Vivaldi en Chromium 72.0.3626.55, donc ça peut venir d'Adguard. Il faudrait voir avec eux si le souci est connu.
    Tu peux envoyer le screenshot en réponse au mail de confirmation de ton VB-48351 si tu veux

  • Voilà qui est fait. Du coup j'ai bien peur que le bug végète un bon bout de temps.

    Mon étonnement est grand de ne voir apparaitre aucune mention de cette incompatibilité chez les utilisateurs VV anglophones. Aurais-ju pu commettre une erreur de méthodologie ... ?

    Même sans espoir de solution du côté VV, j'aimerais qd même lui donner une certaine visibilité qui ferait peut-être avancé mon pb

  • Salut ! Je pense qu'il faudrait aussi essayer de voir du côté de support Adguard. Si ils n'arrivent pas à reproduire le bug c'est peut-être qu'il y a un souci sur ton installation. Je ne connais pas du tout ces logiciels dits "de sécurité".

  • Salut ra-mon

    J'ai remonté il y a 15 jours et j'attends toujours. https://forum.adguard.com/index.php?threads/chromium-no-longer-seems-compatible-with-the-adguard-extension.30686/

    Que penses-tu de cette info ( un peu technique pour moi) ? Ne pourrait-elle être liée à mon pb ? https://www.zdnet.com/article/chrome-api-update-will-kill-a-bunch-of-other-extensions-not-just-ad-blockers/

  • Bonjour Testudo,
    Je me trompe peut-être mais je ne pense pas que cela soit lié. A ma connaissance, le Chrome Extension Manifest V3 est en cours de développement. Le (regrettable) passage à l'API declarativeNetRequest n'est pas encore définitivement acté.
    Une discussion entre les développeurs d'extensions de blocage et ceux de Chrome a d'ailleurs lieu ici : https://groups.google.com/a/chromium.org/forum/#!topic/chromium-extensions/veJy9uAwS00